Unable to connect to battle.net after installing w3arena

Technical Support topics will be moved here when they are Resolved.

Moderators: Oversight Staff, Processing Staff

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Tue May 17, 2016 10:48 am

As the title suggests, after installing w3arena i haven't been able to connect to the normal battle.net

I've tried the following:

1. Connecting with gproxy varlock
[BNET] connecting t oserver [europe.battle.net] on port 6112
[BNET] resolved and cached server ip address 5.42.181.14
[BNET] connection timed out
[BNET] waiting 90 seconds to reconnect

2. Stealthbot chat bot
[08:42:18 PM] [BNLS] Connected!
[08:42:19 PM] [BNLS] Authorized!
[08:42:19 PM] [BNCS] Connecting to the Battle.net server at europe.battle.net...
[08:42:40 PM] [BNCS] 10060 -- The attempt to connect timed out
[08:42:40 PM] [BNCS] Disconnected.
[08:42:40 PM] [BNCS] The server took too long to respond to your computer. Try choosing a different server in the Settings dialog. If you are connecting to a gateway address, such as useast.battle.net, try using one of the IP addresses listed below it.
[08:42:40 PM] [BNCS] Attempting to reconnect in 1 second...

3. Normal warcraft 1.27
Gets stuck at "Initiating connection to Battle.net..."
Then i get "Unable to connect to Battle.net. You may be trying to connect to an invalid Battle.net server. If you are using a modem, you may need to manually connect to the Internet before connecting to Battle.net

4. I tried every battle.net realm and i get the same results.

I can't connect to any battle.net realms except w3arena.
I can connect to the Blizzard client and play hearthstone.

Any ideas? Searching the w3arena forums wasn't very helpful.

PS: I cleared and renewed my dns cache with ipconfig/renew and /flush yesterday. Could this be related?

Stealer
Protector of Nature
Posts: 3158
Joined: Thu Sep 26, 2013 9:37 pm
Has thanked: 18 times
Been thanked: 47 times

Re: Unable to connect to battle.net after installing w3arena

Postby Stealer » Tue May 17, 2016 10:59 am

Win7 64bit?
Wc3 says in bottom left corner when booted 1.27.cxxxx?

What's the registry values for your bnet server list.

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Tue May 17, 2016 11:24 am

Yes, win 7 64 bit. But i didn't have trouble with wc3 until recently.
https://entgaming.net/customstats/legio ... =sylphrena

Yes, it is 1.27

Are these the registry values you're looking for?

Code: Select all

1012
00
127.0.0.1
-1
w3arena
uswest.battle.net
8
Lordaeron (U.S. West)
useast.battle.net
6
Azeroth (U.S. East)
asia.battle.net
-9
Kalimdor (Asia)
europe.battle.net
-1
Northrend (Europe)
localhost
1
GProxy

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Thu May 19, 2016 9:36 am

I uninstalled the game and reinstalled using the official battle.net client downloaded from the website, and that didn't fix anything.

I ran the Battle.net diagnostic tool a few minutes ago and came up with this:

Code: Select all

Running version 2.2

+++ Begin application initialization.
Initializing console...
Assigning console control handler...
Loading the Winsock library...
Initialization complete.

+++ Begin connection test with all servers on a

+++ Begin hostname resolution on a
Querying information about the host... Error! 11001

+++ Begin connection test with all servers on europe.battle.net

+++ Begin hostname resolution on europe.battle.net
Querying information about the host...
Hostname successfully resolved, displaying results...
5.42.181.12
5.42.181.13
5.42.181.14
5.42.181.15
5.42.181.16
5.42.181.17
5.42.181.18
5.42.181.11

+++ Begin connection test with Battle.net server 5.42.181.12
Creating socket...
Binding socket to any available address...
Placing socket into asynchronous mode...
Initiating connection...
Attempting to establish a connection with the server...

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Thu May 19, 2016 5:48 pm

I seem to have found the problem.
I tried to connect through a different computer but wasn't able to.
Then i tried changing my internet to my mobile internet and i was able to connect. Maybe i am ip banned. It's happened before when i messed up the configurations of my chat bot.

User avatar
HazarDous
Staff Department
Posts: 8985
Joined: Mon Jan 12, 2015 9:36 pm
Has thanked: 61 times
Been thanked: 221 times

Re: Unable to connect to battle.net after installing w3arena

Postby HazarDous » Mon May 23, 2016 8:51 pm

@Sylphrena

So no more problem?

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Wed May 25, 2016 7:49 pm

The problem still persists. I work around with by using my mobile hotspot to connect to battle.net.
I factory reset my router and upgraded its firmware.
Does anyone have any ideas?

User avatar
pearson
Armored Tree
Posts: 75
Joined: Mon Apr 18, 2016 9:38 pm
Has thanked: 1 time
Been thanked: 3 times

Re: Unable to connect to battle.net after installing w3arena

Postby pearson » Fri May 27, 2016 12:25 pm

Sylphrena wrote:The problem still persists. I work around with by using my mobile hotspot to connect to battle.net.
I factory reset my router and upgraded its firmware.
Does anyone have any ideas?


Change your IP - Contact your ISP to change your IP in case you are unable to do it yourself
" Nearly all men can stand adversity, but if you want to test a man's character, give him power. " -Abraham Lincoln

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Sun May 29, 2016 5:03 pm

Alright. I will try that

User avatar
HazarDous
Staff Department
Posts: 8985
Joined: Mon Jan 12, 2015 9:36 pm
Has thanked: 61 times
Been thanked: 221 times

Re: Unable to connect to battle.net after installing w3arena

Postby HazarDous » Thu Jun 02, 2016 7:35 am

@Sylphrena

Update?

User avatar
Sylphrena
Aura Tree
Posts: 48
Joined: Sat Jul 18, 2015 12:34 pm
Location: Australia
Has thanked: 2 times

Re: Unable to connect to battle.net after installing w3arena

Postby Sylphrena » Thu Jun 02, 2016 8:36 pm

I have been building and troubleshooting my new pc. i haven't tried it yet. Will update as soon as i do it.

khspww94
Forest Walker
Posts: 170
Joined: Fri Jun 20, 2014 8:26 am
Been thanked: 6 times

Re: Unable to connect to battle.net after installing w3arena

Postby khspww94 » Mon Jun 06, 2016 1:14 pm

Alternatively please do consider looking into Eurobattlenet for another platform. It works fine and it comes with proxy which allows you to reconnect in case you disconnect. I have taken my liberty to include the link as below. I hope you find this helpful. Enjoy.

http://eurobattle.net/content/
F®0sT

User avatar
Merex
ENT Staff
Posts: 5510
Joined: Sun Aug 25, 2013 11:45 pm
Location: Azeroth
Has thanked: 269 times
Been thanked: 149 times

Re: Unable to connect to battle.net after installing w3arena

Postby Merex » Thu Jun 30, 2016 3:38 am

@HazarDous No response after the last update, I like to think the issue is resolved.

  • ENT Rules, Guides and more can be found on our Wiki.
  • Contact the staff & interact with others by joining our Discord.
  • Now available: Host A Game UI.

User avatar
HazarDous
Staff Department
Posts: 8985
Joined: Mon Jan 12, 2015 9:36 pm
Has thanked: 61 times
Been thanked: 221 times

Re: Unable to connect to battle.net after installing w3arena

Postby HazarDous » Thu Jun 30, 2016 3:53 am

Re-post with an update, if necessary.


Return to “Processed Support Cases”

Who is online

Users browsing this forum: No registered users and 1 guest